Can not get pytorch working with tensorboard

I came across the same error, I solved by taking the following steps:

  1. Removed all installation of Tensorflow or Tensorboard from the conda environment.
  2. Then by activating the same conda environment, type "pip install -U tb-nightly"
  3. Then type, "pip install -U future"
  4. done

I think it's a version problem.

just run this:

pip install tensorboard==1.14.0

(not pip install tensorboard==1.14)

or just install the tensoflow 1.14.0, which contains the tensorboard 1.14.0:

pip install tensorflow==1.14.0

This version of tensorflow worked for me in pytorch 1.2.

The error log says, among other things,

ImportError: TensorBoard logging requires TensorBoard with Python summary writer installed. This should be available in 1.14 or above.

So, when it tries to import TensorBoard, it's unable to do so because it's missing it in the search path. You can install the latest version (without specifying any version number), as in:

$ conda install -c conda-forge tensorboard

Apart from that, you might also need to install protobuf:

$ conda install -c conda-forge protobuf

These installations should fix the ImportErrors.