Enum type naming conventions in DTO's
Assuming you're talking about an enum
type when you say "enumeration," I wouldn't suffix it with Dto, since that's not really what it is. For example, I wouldn't say CustomerTypeDto
since it's not a DTO representing a customer type. However, it is an enum
representing the type for a CustomerDto
, so maybe CustomerDtoType
would be appropriate.
Personally I would just use a seperate namepspace and the same name for the enumeration type. I think it's important keep the two seperate so that the external one is just a use case projection of the model.