Apple - How to delete kexts in Catalina?
1. Check for System Integrity Protection (SIP)
Open Terminal
and type
csrutil status
if it says
System Integrity Protection status: enabled.
continue to step 2. Else, skip to step 3.
2. Defeat SIP by Rebooting into macOS Recovery mode
- Turn off Mac; turn back on while hodling ⌘ and R.
- Open Terminal from the Utilities menu.
- Type
csrutil disable
- Reboot (
reboot
)
3. Unload, then delete kext
In Terminal
,
- Unload Extension
sudo kextunload /System/Library/Extensions/AppleThunderboltNHI.kext
- Delete Extension
sudo mount -rw / # mount root as RW
sudo rm -rf /System/Library/Extensions/AppleThunderboltNHI.kext
4. Re-enable SIP (if turned off)
Follow the steps for 2. except type csrutil enable
on step 2.3.
For Mac OS Big Sur
Reboot in rescue mode (reboot while "Cmd + R")
Utilities -> Terminal
csrutil disable
csrutil authenticated-root disable
mount -uw /Volumes/[MacOS ]
delete (or rename, or move elsewhere) the AppleThunderboltNHI.kext directory (I've moved all thunderbolt kext directories since I have no needs about this interface, but I think it works only by disabling AppleThunderboltNHI)
cd /Volumes/Macos (Enter WHATEVER YOUR MACOS DRIVE NAME IS, my macOS drive name is Macos)/System/Library/Extensions
rm -rf AppleThunderboltNHI.kext
- Remove cache
rm -rf /System/Library/Caches/*
- REBUILD the extensions cache ! (new has-to-do in Big Sur...)
kmutil install -u --force --volume-root /Volumes/[MacOS ]
- DON'T FORGET to create another system snapshot to take these modifications under account at next reboot
bless --folder /Volumes/[MacOS ]/System/Library/CoreServices --bootefi --create-snapshot
- reboot (in rescue mode). This step may be unnecessary, not tested straight to
- csrutil enable
- Reboot
Open Terminal and enter the following command:
sudo kextunload /System/Library/Extensions/AppleThunderboltNHI.kext
If that fails to work, you can also just force-delete the kext using
Use the following Terminal command to remove the kext file:
sudo rm -rf /System/Library/Extensions/AppleThunderboltNHI.kext
Restart your MAC