How to start docker from command line in mac
On macOS
you'd use launchctl
:
It's unclear which service you are actually intending to run, although the equivalent to service
or systemctl
on Linux
is launchctl
on macOS
(eg. running docker registry with launchd
):
Copy the Docker registry plist into place:
plutil -lint registry/recipes/osx/com.docker.registry.plist
cp registry/recipes/osx/com.docker.registry.plist ~/Library/LaunchAgents/
chmod 644 ~/Library/LaunchAgents/com.docker.registry.plist
Start the Docker registry:
launchctl load ~/Library/LaunchAgents/com.docker.registry.plist
Restart the docker registry service
launchctl stop com.docker.registry
launchctl start com.docker.registry
Unload the docker registry service
launchctl unload ~/Library/LaunchAgents/com.docker.registry.plist
↳ Run the Docker Registry under launchd
You can open Docker Desktop on Mac using:-
open -a Docker
The Mac equivalent to systemctl
or service
is launchctl. But Docker Desktop is, presumably deliberately, packaged both on Mac and Windows as an application, not a service.
For shutdown, this:
pkill -SIGHUP -f /Applications/Docker.app 'docker serve'
seems to work about as well as Quitting Docker from the GUI. By which I mean (a) when you restart Docker again it starts up with no complaints and (b) however I quit Docker Desktop, I still have a docker networking daemon left running.