Is there a convention on which name to use for a throwaway variable? (Like underscore in Python)
Actually you can write {_, foo} = . . .
and it works, as noted in How to ignore list elements when extracting with pattern matching.
If one is going to make use of this it may be desirable to turn Off
Set::nosym
.
Off[Set::nosym]
{a, _, b} = {1, 2, 3};
{a, b}
{1, 3}
Perhaps this is as close to a convention as we can find?
This one should not need to suppress messages:
Block[{a}, {a, b, a} = {1, 2, 3}];
a
b
(* a *)
(* 2 *)