Is or Are to prefix boolean values

Firstly, isPointersNull is just ugly. Don't do that.

I typically go with any or all, as are can be ambiguous. Does it mean "there are null pointers" or "the pointers are all null"? anyPointersNull and allPointersNull clear that up, IMO.


Please don't use isPointersNull. Consistency is no reason to sacrifice on grammar and readability.


It depends on the language. If you are using Java, 'isPointersNull' will be interpreted as the 'pointersNull' field where 'arePointersNull' will not if you are using any JavaBean processing tools.

I agree that readability is paramount but bean conventions allow common parsing of objects.


isPointersNull looks like a typo. arePointersNull communicates nicely the fact that more than a single object is involved in the consideration of this boolean. But if you want consistency you could refer to an array or collection, which your Pointers ought to be:

  • isPointerArrayNull
  • isPointerCollectionEmpty
  • etc.

Tags:

Coding Style