Mac OS X: Best Way to Make an ISO from a CD or DVD
There are generally four ways to create a disk image on an OS X box:
Disk Utility - The on-screen prompts will guide you, but it will by default create a .dmg, which is an OS X-specific file format. Disk Utility will also create an ISO (.cdr extension) if you select the "CD/DVD Master" option before creating the image. You can rename the extension (to .iso) after creation if desired.
Roxio Toast - The de facto third-party standard in creating optical media on Mac OS for over a decade, it will create almost any CD or DVD format you want.
The
hdiutil
command-line utility, which will, in fact, create every format that Toast supports, for free, though it is far less pretty. If you want to create an ISO with this tool, usehdiutil makehybrid -iso -joliet -o Image.iso /input_path
There is a fourth, extremely direct command-line way using
dd
that sysadmins might know:dd if=/dev/disk1 of=Image.iso
Open /Application/Utilities/Terminal.app/
sudo diskutil unmount /dev/disk1
dd if=/dev/disk1 of=~/myCD.iso bs=2048 conv=sync,notrunc
That should do it!
Actually Disk Utility will create an ISO (.cdr extension). Just ensure you select the "CD/DVD Master" option before creation the image.
That file can then be used like any other ISO file only requiring a rename for certain dumb Windows apps that baulk at the .cdr extension.
Been using this method for ages with no problems.