Solidity error: Expected identifier, got 'LParen'

I have faced this problem with the constructor in solidity too this can be solved really easily

if you are running your code in VSCODE than you may have installed a extension Solidity Extended

then you have then UNININSTALL it and reload your vscode editor

if you may have uinstalled and not reloaded your vs code than you will face same problem

> also set the pragma solidity version to pragma solidity >=0.4.21 < 0.7.0;

this worked for me

See the answer to a similar error here: I'm reposting for convenience...

I had a similar problem. In my case it was the system version of solc I had installed. Here's what I had. I had solc installed through Homebrew, and also truffle installed. when I run truffle version:

Truffle v4.1.14 (core: 4.1.14)
Solidity v0.4.24 (solc-js)

So I had the latest version of truffle and seemingly, solc as well. However, when I run solc --version

solc, the solidity compiler commandline interface
Version: 0.4.19+commit.e67f0147.Darwin.appleclang

My system solidty version was different. I found that I had installed solidity through Homebrew (on Mac), so that was different from the version truffle was using. So the fix in my case, was to upgrade solidity using homebrew, it upgraded from 0.4.19 to 0.4.24 and my problem went away. To upgrade solidity using Homebrew:

brew update
brew upgrade
brew tap ethereum/ethereum
brew install solidity
brew linkapps solidity

The first two lines are probably all you need if you already have solidity installed, but added the rest for completeness.

This was on Mac, if you're on Linux, it might be a similar problem, make sure you upgrade the system installation of solidity, not what's installed with truffle.