string.IsNullOrEmpty() vs string.NotNullOrEmpty()
Double negatives are usually discouraged in naming stuff. !string.NotNullOrEmpty(...)
would make one.
Because "IsNullOrEmpty" is easier to understand than "NotNullOrEmpty". The latter could be interpreted as:
- It's not null and it's not empty
- It's not null or it is empty