What is correct: widget.rowconfigure or widget.grid_rowconfigure?
If you browse Tkinter.py, you'll find that rowconfigure is just a reference to grid_rowconfigure.
widget.rowconfigure
is literally just an alias for widget.grid_rowconfigure
. In the source code for tkinter is this line of code:
rowconfigure = grid_rowconfigure
I don't know for a fact, but I suspect that widget.rowconfigure
was just added for convenience. Frankly, I didn't even know it existed until I read this question.
In my opinion, grid_rowconfigure
is the proper name to use. I say that because tkinter is an interface to an underlying tcl/tk interpreter, and in tcl/tk the command is grid rowconfigure
. Since most tkinter functions mirror the naming conventions of the tcl/tk functions as close as possible, grid_rowconfigure
is the natural choice.