What is this pattern called?
Or Fluent Interface
Method chaining. (Wikipedia)
The answer is provided by Boldewyn, I am just writing this as a suggestion.
When chaining methods like this, try to write it as follows -
string s = new string("Hello World")
.Replace(" ","_")
.ToLower()
.ToUpper();
This improves code readability.